Close

Printing issues - Windows 10 Pro + Secure Lockdown MAE

Posted: one year ago Quote #17723
Hi!

We have a computer running Windows 10 Pro and Secure Lockdown MAE (build: 2.00.198).
All of a sudden printing has stopped working when Secure Lockdown is active.

The application prints but nothing shows up in the printer queue.
If we disable Secure Lockdown printing works fine.
After some testing we also noticed that printing works if we disable the option "no desktop".

We've tested different printers but no difference.
The system is very tightly locked down and no updates has been performed.

Any idea what could be causing this?

Thanks in advance!

Regards,
Johan
Posted: one year ago Quote #17738
The "No Desktop" option removes the Windows Shell which seems to be a requirement for the setup you have to print. Something must of changed in the procedure or setup you had previously. Are you printing from a browser? Was the browser updated?
Posted: one year ago Quote #17742
We're printing from an application (BMG Labtech - MARS).
We're using the same application together with Secure Lockdown MAE on another computer and on that computer printing works fine. Both are setup the same way lockdown-wise.

We've tried deselecting "No desktop" and using the options for no desktop icons, no windows shell etc but it has no effect.
It's only when all the options are turned off that printing starts working.

After some investigation we've found that KB4552152 was installed on the computer on April 15th which was right before the issues started.
We've found several reports that this update cause printing issues so we suspect that is has something to do with our problems.

We're not sure how the update was installed since "No windows updates" are enabled in Secure Lockdown and the Windows Update service is disabled on the computer.

Have you encountered any other issues related to this KB?
Posted: one year ago Quote #17743
Thanks for the detailed explanation. Try uninstalling the Windows Update. Please see the following article regarding best practices for locking down a system. There is a section to follow ("Disabling the Windows Update Service") regarding no Windows Updates.

https://www.inteset.com/how-to-strip-down-windows-10-for-kiosks-digital-signage-and-other-special-purpose-systems
Posted: one year ago Quote #17768
The issue is solved - but not explained...

Solution:
We created a new Windows-account on the computer and with the new account printing works fine with the exact same setup in Secure Lockdown.

It would be a nice bonus to identify what was causing the issue on the old account but I don't know if that's possible.
Posted: one year ago Quote #17873
Reopening this case since the issue has returned on the new account.
This time I've verified that nothing has changed on the system.

After some testing I've found that the issue only occurs while printing from the applications when they're started from circledock. If I start the application from it's "normal" shortcut printing works fine.
To verify I launched two sessions of the application at the same time, one from circledock and one from it's regular shortcut.
The one launched from circledock has printing issues but the other one works fine.

I've tried removing the shortcut from circledock and recreating it but it had no effect.
I've also deleted the circledock-settings for the windows user and recreated them from scratch but without success.
Posted: one year ago Quote #17874
If the printer is a Network printer, try connecting it directly via USB.
Posted: one year ago Quote #17875
That's not an option. The printer is a MFP located in another room.
As a workaround I've setup Secure Lockdown to use Windows start menu for launching applications. With that setup printing works fine.

Correct me if I'm wrong but isn't the version of CircleDock that's being used from 2008?