Close

Secure Lockdown IE edition and Hot Virtual Keyboard

Posted: 7 years ago Quote #709
Hello,
I am currently setting a simple kiosk which needs to run a website and some local HTML pages.
As it will run on a big touchscreen, I need an on-screen keyboard and I chose Hot Virtual Keyboard which is great and cheap.
At the moment, I do not have the set-back box computer that will be used in the final project but I have to show the client that everything works great in order to prove that I will be able to set the kiosk up right away once I get the set-back box. In order to do that, I use Hot Virtual Keyboard and Secure Lockdown trial versions, I will purchase the softwares once I get the set-back box computer as well.

My issue is that Hot Virtual Keyboard and Secure Lockdown don't seem to get along very well as when I run IE without Secure Lockdown, the pop-up keyboard works flawlessly but when I launch Secure Lockdown, it won't show up anymore.
Is there a parameter I need to set to make them work together? Could it be because Hot Virtual Keyboard trial version opens a Windows dialog box asking to purchase the software? In that case, is there a way to click on this box in order to disable it before Secure Lockdown launches?
Getting the multi-app would be pointless as I am just going to use a browser and the site I need to run works fine on IE.

Thanks for your help,
Regards,
Ludo
Posted: 7 years ago Quote #710
Hot Virtual Keyboard should work for your setup. They may have changed something recently that makes it not work with Secure Lockdown. We will look into this and get back to you shortly.
Posted: 7 years ago Quote #711
Thanks for your support :)
FYI, I use Secure Lockdown IE build 2.00.045 and Hot Virtual Keyboard 7.1.8.0
Posted: 7 years ago Quote #713
It is likely that you're running Secure Lockdown with the "Disable Desktop" option checked. When Secure Lockdown is running (with the Desktop disabled), if you want to run a secondary app, you'll need to start it from the Windows Task Scheduler. In Windows 8, you will also need to start it with admin privilages. To do that, you'll need to start HVK with Inteset's included "Process Launcher" utility. So, for Hot Virtual Keyboard, create the following Task Scheduler task to have Hot Virtual Keyboard (or any other secondary app) run when the user logs in.

Trigger: "At log on"
Actions: "Start a program"
Action Program Location: "C:\Program Files\Inteset\Secure Lockdown\ProcessLauncher"
Action Arguments: hvk "C:\Program Files\HotVirtualKeyboard\hvk.exe" "" "C:\Program Files\HotVirtualKeyboard" true

If you would like to receive a file to import the above task into the Task Scheduler, email Tech Support with the request.
Posted: 7 years ago Quote #714
Thanks again for your help, I just tried to add a task with the arguments you told me. It doesn't work but I think it's because I use a Hot Virtual Keyboard trial version at the moment and the trial dialog box can't show up when using Secure Lockdown.
I think I will have to buy a full version of Hot Virtual Keyboard in order to set up the kiosk.

I will let you know when I get the full version in case someone else has the same problem someday.
Posted: 7 years ago Quote #715
It should work with the Trial version. We have it working perfectly here. Make sure your Task Scheduler parameters are correct. Email support if you want to the task import file. Also note if you're running a 64 bit OS, then you need to change the Action Program Location to reflect "C:\Program files (x86)\"
Posted: 7 years ago Quote #716
OK I will contact tech support in that case.
At the moment, I have a 32-bit Windows 8 trial installed on my machine.
Thanks.
Posted: 7 years ago Quote #719
I installed Hot Virtual Keyboard 8 instead of 7.1 without touching any setting and it behaves exactly like I wanted to thanks to your script.

Thanks again. :)
Regards
Posted: 7 years ago Quote #748
I seem to got it running by defining Hot Virtual Keyboard as a background application.