Close

Error while trying to activate SL v2

Posted: 10 years ago Quote #118
Hello !

The whole day I'm trying to activate SL, I purchased it yesterday. under all possible circumstances, after I press "Activate" key error is always the same:

Error processing the product key.
Ensure the system is connected to the Internet.
Unable to register. Server was unable to process request. ---> Requested registry access is not allowed.

at the very same time, I can browse freely via IE, without setting any special settings.

I tried to run this under different accounts, including Admin and User (under the latter is SL set up)

I tried to run via "Start with administrative rights" in context menu.

I switched off Windows Firewall.

Nothing changes !

If I input the code wrong - the error message is quite different. That means, I do not make an error in code input.

Win7 Home Basic, 32 bit, Russian version.

We need to supply this kiosk urgently !! But I cannot do it unless SL is activated !

PLEASE HELP.

Kirill Marchuk
Posted: 10 years ago Quote #120
Are you sure your company/network doesnt require a proxy to access the internet? Currently Secure Lockdown doesn't support the use of proxies to access the internet. Note the product activation is the only part of Secure Lockdown that requires internet access. Once activated, it no longer needs the internet.
Posted: 10 years ago Quote #124
this PC doesn't use proxy server. We have tried different ISPs as well.

And obviously it GETS answer from Server, so that implies, I believe, that HTTP transport is functioning:

Unable to register. Server was unable to process request.

again I have to mention that, whenever this EXACT message is discussed on boards all over the Internet, everywhere it is finally diagnosed as a server-side problem (more specifically, SOAP service impersonates itself as ASPNET user, which doesn't have a necessary hive with a proxy settings in a registry)

anyway are you sure that your registration service is working nowadays ?

I will be waiting for a reply. Please remember that our local time is GMT+6 and yours probably is GMT-6 or so, so we have almost a day-long gap between messages. That's why I beg you to answer us more quickly.

Also, if you are sure that it's all fine on your side, how else could we solve a problem ? can we check some registry- or file-settings to be quite sure what SL is using as its proxy/internet parameters ?

Can it also be a Cryptography issue ? As long as we are using  Russian version of Win7, may be it has some cryptography functionality cut off... due to US export limitations, maybe. just a crazy idea...
Posted: 10 years ago Quote #125
We have activated 1000s of SL licenses and have not run into this issue. this is not a server side issue. We have not  received any errors on this side. After further investigation, it looks as though it's having trouble writing to the local Windows registry. Does the user have admin privileges? Have you tried running SL on a different computer to see if you get the same results? It's likely a local configuration issue that's preventing SL from being able to write to the registry.
Posted: 10 years ago Quote #126
Yes, we have tried under different accounts, all users having a administrative level of access, and we also launched the application using "Start with administrative rights"

We have not tried another PC yet...

which registry branches should the user have rights to write to ? I'll check them all manually.

and, are you sure, that for this (registry writing) is used exactly that user, which has started an application ? maybe impersonation also takes place on a client-side ?
Posted: 10 years ago Quote #128
Secure Lockdown writes to the registry as the current user in all cases and does not use impersonate in any instance.
Posted: 10 years ago Quote #129
as soon as I have prepared everything to collect evidences...

I pressed Activate and successfully activated the program..

for me it's quite clear that something changed on your side, although I cannot prove it.

Anyway, thanks for the support.
Posted: 9 years ago Quote #130
Glad it's working now... We did not change a thing. If you determine the cause, please let us know what you find.